Instalacion de aplicación en .NET

Tanto lo usuarios como los que están pensando si serán usuarios o no, tienen en este foro un lugar común para preguntar, responder e informarse.
rcarlillos
Mensajes: 32
Registrado: Mar 12 Sep, 2006 11:07 pm
Ubicación: México
Contactar:

Mensajepor rcarlillos » Mié 06 Jun, 2007 9:57 pm

Que bueno que pudiste resolver tu problema y gracias a ti por compartir con todos la solución.

Saludos :wink:

laloivol
Mensajes: 3
Registrado: Vie 25 May, 2007 5:10 pm

Mensajepor laloivol » Mié 06 Jun, 2007 6:21 pm

Gracias, de hecho encontré el artículo completo:

http://support.microsoft.com/kb/837376/

Lo malo es que esto no resolvió mi problema, tenía un NullReferenceException, incluso después de seguir las instrucciones que me mandaste y la liga que acabo de escribir.

Pero acabo de resolverlo!!! Estoy utilizando Spring, y en mi Web.config tenía lo siguiente:

<httpModules>
<add>
<add>
</httpModules>

Por alguna inspiración divina me di cuenta de que el problema es que la sesión se cargaba DESPUÉS de las configuraciones y páginas del Spring, así es que cuando intentaba acceder a una página cualquiera, me mandaba la excepción porque la sesión (con todas sus variables) no se había cargado todavía. La solución fue simple, intercambiar los módulos de lugar:

<httpModules>
<add>
<add>
</httpModules>

Et voilà! Increíble no?
Después de esto instalé otra aplicación parecida en el mismo servidor y entonces sí me mandaba un error de SharePoint, que decía que no era compatible con el Framework 2.0 de .NET, en este caso sólo tuve que incluir la ruta de la aplicación en "excluded paths" como lo mencionas y listo! Muchas gracias
--laloivol--


laloivol
Mensajes: 3
Registrado: Vie 25 May, 2007 5:10 pm

Instalacion de aplicación en .NET

Mensajepor laloivol » Lun 28 May, 2007 10:19 pm

Desarrollé un sistema utilizando ASP.NET 2.0 y lo he probado en varios servidores sin problemas. La situación es que el servidor donde mi cliente necesita que lo instale tiene Sharepoint 2003 y me ha hecho toparme con algunos problemas.

El primero fue el siguiente: al abrir la página principal aparecía

Código: Seleccionar todo

Session state can only be used when enableSessionState is set to true, either in a configuration file or in the Page directive. Please also make sure that System.Web.SessionStateModule or a custom session state module is included in the <configuration>\<system.web>\<httpModules> section in the application configuration.


Logré resolverlo utilizando la siguiente línea en el web.config

Código: Seleccionar todo

<httpModules>
            <add name="Session" type="System.Web.SessionState.SessionStateModule"/>
      </httpModules>


Pero ahora tengo otro error de tipo NullReferenceException. Cabe aclarar nuevamente que mi aplicación está corriendo sin problemas en otros servidores de prueba, y todas mis instancias de objetos están inicializadas. Alguién sabe que ocurre aquí? Se los agradeceré infinitamente pues es algo urgente.
--laloivol--


Volver a “Microsoft SHAREPOINT”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado